Skip to main content

References

The research and standards that Penthera’s methodology and per-finding sources cite, in APA 7th edition style, grouped by topic and sorted alphabetically by first author within each group. The BibTeX source is references.bib; this page is generated from it by node scripts/build-references.mjs, and a test fails if the two drift or if a citation in METHODOLOGY.md does not resolve to an entry here. Every entry was checked against the publisher or standards body (Crossref DOI metadata, USENIX, NDSS, arXiv, the RFC Editor, OWASP, MITRE, OASIS, the EU Publications Office) on 2026-10-19. Entries that could not be verified were left out, and so were fields (pages, volume, issue, editors) that the publisher’s metadata does not record. Each entry has an anchor named after its BibTeX key, for example #bau2010state, which is also the key reports and SARIF use. Entries marked † are further reading: they inform the work but are not cited in the methodology.

Black-box scanning and benchmarking

Antunes, N., & Vieira, M. (2010). Benchmarking vulnerability detection tools for web services. In 2010 IEEE International Conference on Web Services (ICWS) (pp. 203–210). IEEE. https://doi.org/10.1109/ICWS.2010.76 Antunes, N., & Vieira, M. (2015). Assessing and comparing vulnerability detection tools for web services: Benchmarking approach and examples. IEEE Transactions on Services Computing, 8(2), 269–283. https://doi.org/10.1109/TSC.2014.2310221 Bau, J., Bursztein, E., Gupta, D., & Mitchell, J. (2010). State of the art: Automated black-box web application vulnerability testing. In 2010 IEEE Symposium on Security and Privacy (pp. 332–345). IEEE. https://doi.org/10.1109/SP.2010.27 Doupé, A., Cova, M., & Vigna, G. (2010). Why Johnny can’t pentest: An analysis of black-box web vulnerability scanners. In C. Kreibich & M. Jahnke (Eds.), Detection of Intrusions and Malware, and Vulnerability Assessment (DIMVA 2010) (pp. 111–131). Springer. https://doi.org/10.1007/978-3-642-14215-4_7 Durumeric, Z., Li, F., Kasten, J., Amann, J., Beekman, J., Payer, M., Weaver, N., Adrian, D., Paxson, V., Bailey, M., & Halderman, J. A. (2014). The matter of Heartbleed. In Proceedings of the 2014 Conference on Internet Measurement Conference (IMC ‘14) (pp. 475–488). ACM. https://doi.org/10.1145/2663716.2663755 Kar, A., Natadze, A., Branca, E., & Stakhanova, N. (2022). HTTPFuzz: Web server fingerprinting with HTTP request fuzzing. In Proceedings of the 19th International Conference on Security and Cryptography (pp. 261–271). SCITEPRESS. https://doi.org/10.5220/0011328900003283 Lee, D., Rowe, J., Ko, C., & Levitt, K. (2002). Detecting and defending against web-server fingerprinting. In 18th Annual Computer Security Applications Conference, 2002. Proceedings. (pp. 321–330). IEEE Computer Society. https://doi.org/10.1109/CSAC.2002.1176304 Lyon, G. (2009). Nmap network scanning: The official Nmap project guide to network discovery and security scanning. Insecure.Com LLC. https://nmap.org/book/vscan.html Nappa, A., Johnson, R., Bilge, L., Caballero, J., & Dumitras, T. (2015). The attack of the clones: A study of the impact of shared code on vulnerability patching. In 2015 IEEE Symposium on Security and Privacy (pp. 692–708). IEEE. https://doi.org/10.1109/SP.2015.48 OWASP Foundation. (n.d.-a). OWASP Benchmark project (Version 1.2). Retrieved October 19, 2026, from https://owasp.org/www-project-benchmark/ ProjectDiscovery. (n.d.). Nuclei-templates: Php-detect.yaml. Retrieved October 21, 2026, from https://github.com/projectdiscovery/nuclei-templates/blob/main/http/technologies/php-detect.yaml Vasek, M., Wadleigh, J., & Moore, T. (2016). Hacking is not random: A case-control study of webserver-compromise risk. IEEE Transactions on Dependable and Secure Computing, 206–219. https://doi.org/10.1109/TDSC.2015.2427847

Security design principles

Saltzer, J. H., & Schroeder, M. D. (1975). The protection of information in computer systems. Proceedings of the IEEE, 63(9), 1278–1308. https://doi.org/10.1109/PROC.1975.9939 † Schneier, B., & Kelsey, J. (1999). Secure audit logs to support computer forensics. ACM Transactions on Information and System Security, 2(2), 159–176. https://doi.org/10.1145/317087.317089

Threat modeling

Kohnfelder, L., & Garg, P. (1999). The threats to our products [Internal publication]. Microsoft. Retrieved October 19, 2026, from https://shostack.org/files/microsoft/The-Threats-To-Our-Products.docx Shostack, A. (2014). Threat modeling: Designing for security. Wiley. https://www.wiley-vch.de/de/fachgebiete/computer-und-informatik/threat-modeling-978-1-118-80999-0

Software supply chain

Ladisa, P., Plate, H., Martinez, M., & Barais, O. (2023). SoK: Taxonomy of attacks on open-source software supply chains. In 2023 IEEE Symposium on Security and Privacy (SP) (pp. 1509–1526). IEEE. https://doi.org/10.1109/SP46215.2023.10179304 Lauinger, T., Chaabane, A., Arshad, S., Robertson, W., Wilson, C., & Kirda, E. (2017). Thou shalt not depend on me: Analysing the use of outdated JavaScript libraries on the web. In Proceedings 2017 Network and Distributed System Security Symposium. Internet Society. https://doi.org/10.14722/ndss.2017.23414 Ohm, M., Plate, H., Sykosch, A., & Meier, M. (2020). Backstabber’s knife collection: A review of open source software supply chain attacks. In C. Maurice, L. Bilge, G. Stringhini, & N. Neves (Eds.), Detection of Intrusions and Malware, and Vulnerability Assessment (DIMVA 2020) (pp. 23–43). Springer. https://doi.org/10.1007/978-3-030-52683-2_2 Samuel, J., Mathewson, N., Cappos, J., & Dingledine, R. (2010). Survivable key compromise in software update systems. In Proceedings of the 17th ACM Conference on Computer and Communications Security (CCS ‘10) (pp. 61–72). ACM. https://doi.org/10.1145/1866307.1866315 Thompson, K. (1984). Reflections on trusting trust. Communications of the ACM, 27(8), 761–763. https://doi.org/10.1145/358198.358210 Torres-Arias, S., Afzali, H., Kuppusamy, T. K., Curtmola, R., & Cappos, J. (2019). in-toto: Providing farm-to-table guarantees for bits and bytes. In 28th USENIX Security Symposium (USENIX Security 19) (pp. 1393–1410). USENIX Association. https://www.usenix.org/conference/usenixsecurity19/presentation/torres-arias Zimmermann, M., Staicu, C.-A., Tenny, C., & Pradel, M. (2019). Small world with high risks: A study of security threats in the npm ecosystem. In 28th USENIX Security Symposium (USENIX Security 19) (pp. 995–1010). USENIX Association. https://www.usenix.org/conference/usenixsecurity19/presentation/zimmerman

Secret leakage

Basak, S. K., Neil, L., Reaves, B., & Williams, L. (2023). SecretBench: A dataset of software secrets. In 2023 IEEE/ACM 20th International Conference on Mining Software Repositories (MSR) (pp. 347–351). IEEE. https://doi.org/10.1109/MSR59073.2023.00053 Meli, M., McNiece, M. R., & Reaves, B. (2019). How bad can it Git? Characterizing secret leakage in public GitHub repositories. In Proceedings 2019 Network and Distributed System Security Symposium. Internet Society. https://doi.org/10.14722/ndss.2019.23418

Web application security

Barth, A., Jackson, C., & Mitchell, J. C. (2008). Robust defenses for cross-site request forgery. In Proceedings of the 15th ACM Conference on Computer and Communications Security (CCS ‘08) (pp. 75–88). ACM. https://doi.org/10.1145/1455770.1455782 Chen, J., Jiang, J., Duan, H., Wan, T., Chen, S., Paxson, V., & Yang, M. (2018). We still don’t have secure cross-domain requests: An empirical study of CORS. In 27th USENIX Security Symposium (USENIX Security 18) (pp. 1079–1093). USENIX Association. https://www.usenix.org/conference/usenixsecurity18/presentation/chen-jianjun Crosby, S. A., Wallach, D. S., & Riedi, R. H. (2009). Opportunities and limits of remote timing attacks. ACM Transactions on Information and System Security, 12(3), 1–29. https://doi.org/10.1145/1455526.1455530 Fett, D., Küsters, R., & Schmitz, G. (2016). A comprehensive formal security analysis of OAuth 2.0. In Proceedings of the 2016 ACM SIGSAC Conference on Computer and Communications Security (CCS ‘16) (pp. 1204–1215). ACM. https://doi.org/10.1145/2976749.2978385 Hodges, J., Jackson, C., & Barth, A. (2012). HTTP strict transport security (HSTS) (RFC 6797). RFC Editor. https://doi.org/10.17487/RFC6797 Jones, M., Bradley, J., & Sakimura, N. (2015). JSON web token (JWT) (RFC 7519). RFC Editor. https://doi.org/10.17487/RFC7519 Kitterman, S. (2014). Sender policy framework (SPF) for authorizing use of domains in email, version 1 (RFC 7208). RFC Editor. https://doi.org/10.17487/RFC7208 Kocher, P. C. (1996). Timing attacks on implementations of Diffie-Hellman, RSA, DSS, and other systems. In N. Koblitz (Ed.), Advances in Cryptology – CRYPTO ‘96 (pp. 104–113). Springer. https://doi.org/10.1007/3-540-68697-5_9 Kucherawy, M., & Zwicky, E. (2015). Domain-based message authentication, reporting, and conformance (DMARC) (RFC 7489). RFC Editor. https://doi.org/10.17487/RFC7489 Lavrenovs, A., & Melon, F. J. R. (2018). HTTP security headers analysis of top one million websites. In 2018 10th International Conference on Cyber Conflict (CyCon) (pp. 345–370). IEEE. https://doi.org/10.23919/CYCON.2018.8405025 Lekies, S., Stock, B., & Johns, M. (2013). 25 million flows later: Large-scale detection of DOM-based XSS. In Proceedings of the 2013 ACM SIGSAC Conference on Computer and Communications Security (CCS ‘13) (pp. 1193–1204). ACM. https://doi.org/10.1145/2508859.2516703 Lodderstedt, T., Bradley, J., Labunets, A., & Fett, D. (2025). Best current practice for OAuth 2.0 security (RFC 9700, BCP 240). RFC Editor. https://doi.org/10.17487/RFC9700 OWASP Foundation. (n.d.-b). OWASP Web Security Testing Guide, version 4.2. Retrieved October 19, 2026, from https://wstg.owasp.org/v4.2/ OWASP Foundation. (2021). OWASP Top 10:2021. Retrieved October 19, 2026, from https://top10.owasp.org/2021 OWASP Foundation. (2023). OWASP Top 10 API security risks – 2023. OWASP API Security Project. Retrieved October 19, 2026, from https://owasp.org/API-Security/editions/2023/en/0x11-t10/ OWASP Foundation. (2025c). OWASP Top 10:2025. Retrieved October 19, 2026, from https://top10.owasp.org/2025 The PHP Group. (n.d.-a). Description of core php.ini directives: Expose_php. PHP Manual. Retrieved October 21, 2026, from https://www.php.net/manual/en/ini.core.php Sakimura, N., Bradley, J., & Agarwal, N. (2015). Proof key for code exchange by OAuth public clients (RFC 7636). RFC Editor. https://doi.org/10.17487/RFC7636 Sheffer, Y., Hardt, D., & Jones, M. (2020). JSON web token best current practices (RFC 8725, BCP 225). RFC Editor. https://doi.org/10.17487/RFC8725 Stock, B., Lekies, S., Mueller, T., Spiegel, P., & Johns, M. (2014). Precise client-side protection against DOM-based cross-site scripting. In 23rd USENIX Security Symposium (USENIX Security 14) (pp. 655–670). USENIX Association. https://www.usenix.org/conference/usenixsecurity14/technical-sessions/presentation/stock Stock, B., Pellegrino, G., Rossow, C., Johns, M., & Backes, M. (2016). Hey, you have a problem: On the feasibility of Large-Scale web vulnerability notification. In 25th USENIX Security Symposium (USENIX Security 16) (pp. 1015–1032). USENIX Association. https://www.usenix.org/conference/usenixsecurity16/technical-sessions/presentation/stock Weichselbaum, L., Spagnuolo, M., Lekies, S., & Janc, A. (2016). CSP is dead, long live CSP! On the insecurity of whitelists and the future of Content Security Policy. In Proceedings of the 2016 ACM SIGSAC Conference on Computer and Communications Security (CCS ‘16) (pp. 1376–1387). ACM. https://doi.org/10.1145/2976749.2978363

LLM and agent security

† Amodei, D., Olah, C., Steinhardt, J., Christiano, P., Schulman, J., & Mané, D. (2016). Concrete problems in AI safety [Preprint]. arXiv. https://doi.org/10.48550/arXiv.1606.06565 † Anthropic. (2026, July 30). Investigating three real-world incidents in our cybersecurity evaluations. Retrieved October 20, 2026, from https://www.anthropic.com/news/investigating-incidents-cybersecurity-evals † Baker, B., Huizinga, J., Gao, L., Dou, Z., Guan, M. Y., Madry, A., Zaremba, W., Pachocki, J., & Farhi, D. (2025). Monitoring reasoning models for misbehavior and the risks of promoting obfuscation [Preprint]. arXiv. https://doi.org/10.48550/arXiv.2503.11926 Cloudflare. (2026). Security-audit-skill. Retrieved October 22, 2026, from https://github.com/cloudflare/security-audit-skill/tree/c1c8a8c Ding, Y., Fu, Y., Ibrahim, O., Sitawarin, C., Chen, X., Alomair, B., Wagner, D., Ray, B., & Chen, Y. (2025). Vulnerability detection with code language models: How far are we? In Proceedings of the 47th IEEE/ACM International Conference on Software Engineering (ICSE 2025). https://doi.org/10.48550/arXiv.2403.18624 Greshake, K., Abdelnabi, S., Mishra, S., Endres, C., Holz, T., & Fritz, M. (2023). Not what you’ve signed up for: Compromising real-world LLM-integrated applications with indirect prompt injection. In Proceedings of the 16th ACM Workshop on Artificial Intelligence and Security (AISec ‘23) (pp. 79–90). ACM. https://doi.org/10.1145/3605764.3623985 Liu, Y., Deng, G., Li, Y., Wang, K., Wang, Z., Wang, X., Zhang, T., Liu, Y., Wang, H., Zheng, Y., Zhang, L. Y., & Liu, Y. (2023). Prompt injection attack against LLM-integrated applications [Preprint]. arXiv. https://doi.org/10.48550/arXiv.2306.05499 † METR, & Redwood Research. (2026, August 26). Brief independent investigation of agents’ behavior, reasoning and collaboration in the OpenAI / Hugging Face hacking incident. Retrieved October 20, 2026, from https://metr.org/hugging-face-incident-report-aug-2026.pdf The MITRE Corporation. (n.d.-b). MITRE ATLAS: Adversarial Threat Landscape for AI Systems. Retrieved October 19, 2026, from https://atlas.mitre.org/ † OpenAI. (2026, August 26). OpenAI–Hugging Face incident: Technical report. Retrieved October 20, 2026, from https://cdn.openai.com/pdf/67869394-cb91-4c12-888c-5cbd85c7814c/OpenAI-Hugging-Face%20Incident-Technical-Report.pdf OWASP Foundation. (2024, November 17). OWASP Top 10 for LLM applications 2025. OWASP Gen AI Security Project. Retrieved October 19, 2026, from https://genai.owasp.org/resource/owasp-top-10-for-llm-applications-2025/ OWASP Foundation. (2025a). OWASP MCP Top 10 [Beta]. Retrieved October 19, 2026, from https://owasp.org/www-project-mcp-top-10/ OWASP Foundation. (2025b, December 9). OWASP Top 10 for agentic applications for 2026. OWASP Gen AI Security Project. Retrieved October 19, 2026, from https://genai.owasp.org/resource/owasp-top-10-for-agentic-applications-for-2026/ Perez, F., & Ribeiro, I. (2022). Ignore previous prompt: Attack techniques for language models [Preprint]. arXiv. https://doi.org/10.48550/arXiv.2211.09527 Spracklen, J., Wijewickrama, R., Sakib, A. H. M. N., Maiti, A., Viswanath, B., & Jadliwala, M. (2025). We have a package for you! A comprehensive analysis of package hallucinations by code generating LLMs. In 34th USENIX Security Symposium (USENIX Security 25) (pp. 3687–3706). USENIX Association. https://www.usenix.org/conference/usenixsecurity25/presentation/spracklen † Zhong, Z., Raghunathan, A., & Carlini, N. (2025). ImpossibleBench: Measuring LLMs’ propensity of exploiting test cases [Preprint]. arXiv. https://doi.org/10.48550/arXiv.2510.20270

Standards and regulation

European Parliament and Council of the European Union. (2022). Directive (EU) 2022/2555 of the European Parliament and of the Council of 14 December 2022 on measures for a high common level of cybersecurity across the Union, amending Regulation (EU) No 910/2014 and Directive (EU) 2018/1972, and repealing Directive (EU) 2016/1148 (NIS 2 Directive). Official Journal of the European Union, L 333, 27.12.2022, p. 80. Retrieved October 19, 2026, from https://eur-lex.europa.eu/eli/dir/2022/2555/oj Fanning, M. C., & Golding, L. J. (2023, August 28). Static Analysis Results Interchange Format (SARIF) version 2.1.0 plus errata 01 [OASIS Standard incorporating Approved Errata]. OASIS. Retrieved October 19, 2026, from https://docs.oasis-open.org/sarif/sarif/v2.1.0/errata01/os/sarif-v2.1.0-errata01-os-complete.html FIRST. (2023, November 1). Common vulnerability scoring system version 4.0: Specification document (Version 1.2). Retrieved October 21, 2026, from https://www.first.org/cvss/v4.0/specification-document The MITRE Corporation. (n.d.-a). CWE: Common Weakness Enumeration. Retrieved October 19, 2026, from https://cwe.mitre.org/ † Nationaal Cyber Security Centrum. (2015). ICT-beveiligingsrichtlijnen voor webapplicaties: Richtlijnen [ICT security guidelines for web applications: Guidelines]. Retrieved October 21, 2026, from https://www.ncsc.nl/binaries/ncsc/documenten/publicaties/2019/mei/01/ict-beveiligingsrichtlijnen-voor-webapplicaties/ICT-Beveiligingsrichtlijnen-voor-Webapplicaties-Richtlijnen-Leesversie.pdf Nationaal Cyber Security Centrum. (2024). ICT-beveiligingsrichtlijnen voor webapplicaties [ICT security guidelines for web applications]. Retrieved October 21, 2026, from https://www.ncsc.nl/api/media/sites/default/files/Richtlijn%20ICT%20beveiligingsrichtlijnen%20webapplicaties%2007-24_0.pdf Rock, L., Hagen, S., & Schmidt, T. (2022, November 18). Common security advisory framework version 2.0 [OASIS Standard]. OASIS. Retrieved October 21, 2026, from https://docs.oasis-open.org/csaf/csaf/v2.0/os/csaf-v2.0-os.html Scarfone, K. A., Souppaya, M. P., Cody, A., & Orebaugh, A. D. (2008). Technical guide to information security testing and assessment (NIST Special Publication 800-115). National Institute of Standards and Technology. https://doi.org/10.6028/NIST.SP.800-115 SPDX Workgroup, The Linux Foundation. (n.d.). SPDX License List. Retrieved October 19, 2026, from https://spdx.org/licenses/ † Tabassi, E. (2023). Artificial intelligence risk management framework (AI RMF 1.0) (NIST AI 100-1). National Institute of Standards and Technology. https://doi.org/10.6028/NIST.AI.100-1

Vulnerability advisories and version data

The Apache Software Foundation. (n.d.). Apache HTTP Server 2.4 vulnerabilities. Retrieved October 21, 2026, from https://httpd.apache.org/security/vulnerabilities_24.html Censys. (2024, June 10). PHP-CGI argument injection vulnerability could lead to remote code execution. Retrieved October 21, 2026, from https://censys.com/advisory/cve-2024-4577/ Chang, O., & Cox, R. (2026, October 13). Open source vulnerability format (Version 1.9.2). OpenSSF. Retrieved October 21, 2026, from https://ossf.github.io/osv-schema/ Cybersecurity and Infrastructure Security Agency. (n.d.). Known exploited vulnerabilities catalog. Retrieved October 21, 2026, from https://www.cisa.gov/known-exploited-vulnerabilities-catalog Debian Project. (n.d.). Debian security FAQ. Retrieved October 21, 2026, from https://www.debian.org/security/faq DEVCORE. (2024, June 6). Security alert: CVE-2024-4577 – PHP CGI argument injection vulnerability. Retrieved October 21, 2026, from https://devco.re/blog/2024/06/06/security-alert-cve-2024-4577-php-cgi-argument-injection-vulnerability-en/ endoflife.date contributors. (n.d.). Endoflife.date. Retrieved October 21, 2026, from https://endoflife.date/ Li, F., & Paxson, V. (2017). A large-scale empirical study of security patches. In Proceedings of the 2017 ACM SIGSAC Conference on Computer and Communications Security (CCS ‘17) (pp. 2201–2215). ACM. https://doi.org/10.1145/3133956.3134072 MongoDB, Inc. (n.d.). Software lifecycle schedules. MongoDB. Retrieved October 22, 2026, from https://www.mongodb.com/legal/support-policy/lifecycles Nationaal Cyber Security Centrum. (n.d.). Security advisories. Retrieved October 21, 2026, from https://advisories.ncsc.nl/ nginx. (n.d.). Nginx security advisories. Retrieved October 21, 2026, from https://nginx.org/en/security_advisories.html † NOS. (2026, October 21). Websites kwetsbaar voor softwarelek: RTL nieuws, DigiD en MijnOverheid uit de lucht [Websites vulnerable to software flaw: RTL Nieuws, DigiD and MijnOverheid offline]. Retrieved October 21, 2026, from https://nos.nl/liveblog/2636066-websites-kwetsbaar-voor-softwarelek-digid-en-mijnoverheid-uit-de-lucht OpenJS Foundation and Node.js contributors. (n.d.). Node.js releases. Retrieved October 21, 2026, from https://nodejs.org/en/about/previous-releases OpenSSL Library. (n.d.). Vulnerabilities. Retrieved October 21, 2026, from https://openssl-library.org/news/vulnerabilities/ The PHP Group. (n.d.-b). Security advisories for php/php-src. Retrieved October 21, 2026, from https://github.com/php/php-src/security/advisories The PHP Group. (n.d.-c). Supported versions. Retrieved October 21, 2026, from https://www.php.net/supported-versions.php The PHP Group. (2012, May 6). PHP 5.3.12 and 5.4.2 and the CGI flaw (CVE-2012-1823). Retrieved October 21, 2026, from https://www.php.net/archive/2012.php#id2012-05-06-1 The PHP Group. (2026, October 20). Upcoming critical PHP security release. Retrieved October 21, 2026, from https://www.php.net/archive/2026.php#2026-10-20-1 Python Software Foundation. (n.d.). Status of Python versions. Python Developer’s Guide. Retrieved October 21, 2026, from https://devguide.python.org/versions/ Red Hat. (n.d.). Security backporting practice. Red Hat Customer Portal. Retrieved October 21, 2026, from https://access.redhat.com/security/updates/backporting Ubuntu Security Team. (n.d.). Security/FAQ. Ubuntu Wiki. Retrieved October 21, 2026, from https://wiki.ubuntu.com/SecurityTeam/FAQ Zhang, H., & Qian, Z. (2018). Precise and accurate patch presence test for binaries. In 27th USENIX Security Symposium (USENIX Security 18) (pp. 887–902). USENIX Association. https://www.usenix.org/conference/usenixsecurity18/presentation/zhang-hang